Intentando empaquetar Wallabag para Debian …

21 Feb

wallabag… no es tan sencillo como parecía en un primer momento, pero ahí vamos.

Comienzo reuniendo información sobre la aplicación:

Aunque el autor utiliza git como repositorio voy a optar por bajar la versión estable directamente porque no me veo aún cómodo mezclando git y los útiles de empaquetado de Debian.

Detallo aquí las dependencias del programa junto con los paquetes necesarios para su instalación:

  • PHP versión 5.3.3 o superior: php5
  • Módulos PHP:
    • XML: php-xml-parser
    • PCRE: incluída en el entorno PHP desde 5.3.0
    • Tidy: php5-tidy
    • cURL: php5-curl
    • SQLite: php5-sqlite
    • Como extras:
      • MySQL: php5-mysql
      • PostgreSQL: php5-pgsql
  • Características de PHP activas:
    • Filtrado de datos (incluído en PHP desde la versión 5.2.0).
    • Descarga en paralelo de URL .
    • Directiva
      allow_url_fopen

       activa.

Así que en principio no parece que existan problemas de dependencias para la versión Wheezy de Debian. El único inconveniente con el que me topo, y reconozco que me va a venir bien aprender, es crear los paquetes extras para las bases de datos relacionales. Miraré cuidadosamente cómo lo hacen otros y copiaré lo que pueda entender …